git in Aptana studio 3 fails to recognize SSH key

Oz K's Avatar

Oz K

07 Oct, 2010 09:34 AM

Hi,
I'm using Aptana Studio 3 Beta, build: 3.0.0.201009221205 on windows 7 32 bit.
I installed Git-1.7.3.1-preview20101002.exe and got it to work with plink.exe and my private\public key.
when pushing and pulling using Git bash - authentication is done with the public key, and I'm not prompted for a password.
When I try a push or pull from Aptana - it asks me for a password (there isn't any!).
why doesn't Aptana recognize my running key agent?
I also tried setting the path the git executable in preferences --> git, but to no avail.

any help would be highly appreciated :)

Thanks,
Oz

  1. Support Staff 2 Posted by Max Stepanov on 01 Nov, 2010 09:55 PM

    Max Stepanov's Avatar

    Hi Oz,

    Aptana Studio sets GIT_SSH environment variable to it's internal program which handles SSH password/passphrase prompt in common conditions.
    In case you replacing default ssh.exe executable by setting GIT_SSH to plink.exe, to work with Aptana Studio you also need to set SSH_CMD to the same plink.exe path.

    Regards,
    Max

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac