how to set git user.name and user.email

John Q's Avatar

John Q

16 Jun, 2010 06:05 PM

I noticed that when I do a commit using the gui (specifically the Commit command in the App Explorer gear menu), git isn't using the user.name and user.email from the .gitconf in my home directory. I'm running the Studio 3 Beta plugin in Galileo on Windows XP, and I'm using msysgit 1.7.1. When I do the same commit from the git bash prompt, it works fine. Is there a separate global git config for Studio 3? Is there an easy way to sync this with the .gitconfig in my home directory?

  1. 2 Posted by John Q on 24 Jun, 2010 03:00 PM

    John Q's Avatar

    I've done a bit more testing, and I've found that it is only the author name and email that are not being set correctly, and the problem only surfaces when using the Commit wizard in the project gear menu. Commits performed externally using the msysgit bash or through the terminal window within aptana assign the author and committer correctly based on the settings in the global .gitconfig file in my home directory.

  2. 3 Posted by ashebanow on 25 Jun, 2010 12:58 AM

    ashebanow's Avatar

    If you didn't install our local copy of portablegit, then you should be using the config settings from your msysgit install. But if you have both our portablegit and msysgit installed, then we would pull config settings from portablegit and that would explain the problem. To fix it, quit Studio, then remove your local copy of portablegit (it gets installed in your workspace: look in the .metadata folder for a plugin with a name that matches portablegit and delete it). Then restart Studio3. If it tells you it can't find your git, use the option to tell it where your git is instead of installing portablegit again.

  3. 4 Posted by John Q on 28 Jun, 2010 01:41 PM

    John Q's Avatar

    Thanks for the suggestion. The only plugins I can find related to git are "com.aptana.git.core" and "com.aptana.git.ui", but neither of those seem to contain anything like a git install.

  4. 5 Posted by Carl on 27 Jul, 2010 07:20 PM

    Carl's Avatar

    I removed the portablegit plugin but had the same problem even after restart. Later, I ran the commands

    git config --add user.name "your-user-name"
    git config --add user.email "[email blocked]"
    

    I had done this with git config --global before when setting up git originally, but I theorize that Aptana is using some other, local, setting for these values. YMMV, but it worked for me.

    -C

  5. 6 Posted by ashebanow on 30 Jul, 2010 06:35 PM

    ashebanow's Avatar

    Thanks for the report. You should NOT have needed to uninstall the portablegit plugin from Aptana Studio itself. That plugin just contains a copy of the binaries, which never get executed directly. The way it works is that Studio3 looks for a working msysgit installation at startup. If it doesn't find you, it prompts you to install one. If you choose to install portable git, we COPY the stuff in the plugin into your Aptana Studio 3 Workspace folder, and run the one there. You can just go into your Workspace's .metadata dir and delete the version there next time.

  6. ashebanow closed this discussion on 30 Jul, 2010 06:35 PM.

  7. John Q re-opened this discussion on 02 Aug, 2010 06:30 PM

  8. 7 Posted by John Q on 02 Aug, 2010 06:30 PM

    John Q's Avatar

    I can confirm that Carl's suggestion works without actually uninstalling anything. However, it means that the app explorer isn't "seeing" the global git config file. Carl's workaround hides this by creating the appropriate entries in the local git config file, but that is really only hiding the problem. Can this be converted to a bug ticket, or should we open a new one?

  9. 8 Posted by ashebanow on 02 Aug, 2010 06:38 PM

    ashebanow's Avatar

    Do these tests first, please:

    1) open a new terminal window inside Aptana Studio 3
    2) cd into a directory where one of your projects live (/c/something or other/...)
    3) run the command "which git"
    4) run the command 'git config -l'

    attach the output and let us know if the directory printed by #3 is different from the one you installed manually

  10. 9 Posted by Carl Leubsdorf, Jr. on 02 Aug, 2010 07:14 PM

    Carl Leubsdorf, Jr.'s Avatar

    New repository, created on github and locally today.

    I did a commit via the 'team' context menu and the user name was not set
    properly (cpl - my username on this machine). Commits via command line work
    fine and are tagged with my correct github username. Also note that for
    example if i 'add remote' Aptana prompts me to add a remote git: url with
    'cpl' not 'carlthewebmaster'.

    Output below:

    cpl@XPS420WIN7 /c/xampp/htdocs/tech (master)
    $ which git
    /bin/git

    cpl@XPS420WIN7 /c/xampp/htdocs/tech (master)
    $ git config -l
    core.symlinks=false
    core.autocrlf=true
    color.diff=auto
    pack.packsizelimit=2g
    help.format=html
    http.sslcainfo=/bin/curl-ca-bundle.crt
    sendemail.smtpserver=/bin/msmtp.exe
    user.name=carlthewebmaster
    user.email=[email blocked]
    github.token=f97c16277e9ccfcdc6f6c77c04eed644
    github.user=carlthewebmaster
    gui.recentrepo=C:/xampp/htdocs/git-test
    core.repositoryformatversion=0
    core.filemode=false
    core.bare=false
    core.logallrefupdates=true
    core.symlinks=false
    core.ignorecase=true
    core.hidedotfiles=dotGitOnly
    remote.origin-tech.url=git@github.com:hourly/tech.git
    remote.origin-tech.fetch=+refs/heads/*:refs/remotes/origin-tech/*

    cpl@XPS420WIN7 /c/xampp/htdocs/tech (master)
    $ gitk

  11. 10 Posted by ashebanow on 02 Aug, 2010 09:49 PM

    ashebanow's Avatar

    OK, I've asked one of our engineers to take a look. It doesn't make sense to me immediately, but there must be some way in which the built-in git commands are using a different git setup.

  12. Support Staff 11 Posted by Max Stepanov on 03 Aug, 2010 12:30 AM

    Max Stepanov's Avatar

    Hi all,

    Can you let me know where do you have git installed ? Is it C:\msysgit or C:\Program Files\Git ?

    Thanks,
    Max

  13. 12 Posted by Carl Leubsdorf, Jr. on 03 Aug, 2010 12:51 AM

    Carl Leubsdorf, Jr.'s Avatar

    Git bash shortcut:
    C:\Windows\System32\cmd.exe /c ""C:\Program Files\Git\bin\sh.exe" --login
    -i"

  14. 13 Posted by kanduvisla on 09 Aug, 2010 02:22 PM

    kanduvisla's Avatar

    I have the same issue, I have a local copy of GIT running in C:\Program Files\Git.

    This is my output:

    $ which git /bin/git

    $ git config -l core.symlinks=false
    core.autocrlf=true
    color.diff=auto
    pack.packsizelimit=2g
    help.format=html
    http.sslcainfo=/bin/curl-ca-bundle.crt
    sendemail.smtpserver=/bin/msmtp.exe
    user.name=Giel Berkers
    user.email=[email blocked]
    core.repositoryformatversion=0
    core.filemode=false
    core.bare=false
    core.logallrefupdates=true
    core.symlinks=false
    core.ignorecase=true
    core.hidedotfiles=dotGitOnly

  15. 14 Posted by Adam Michel on 11 Aug, 2010 09:51 AM

    Adam Michel's Avatar

    I'm having the same issue as everyone else. It seems like when using the Team menu Studio 3 is using a different Git configuration. I'm running Git from "C:\Program Files (x86)\Git".

    I've verified my user.name and user.email using git config -l from the repository home. Committing from the command line seems to use the proper user properties also.

  16. 15 Posted by Fábio Damas on 13 Aug, 2010 01:26 AM

    Fábio Damas's Avatar

    I'm having this problem too. Running latest Aptana Studio 3 beta on Ubuntu 10.04 x86_64.

    Already changed the git binary on the Preferences to /usr/bin/git, still doesnt use my local author settings.

  17. 16 Posted by ashebanow on 13 Aug, 2010 01:43 AM

    ashebanow's Avatar

    we think we've figured this out, and have a fix for the next release due next Wednesday.

  18. 17 Posted by mltsy on 31 Aug, 2010 12:31 AM

    mltsy's Avatar

    I downloaded the new Beta today, and am having the same problem. I have global user.name and user.email set, but it's not using them... ?

  19. Support Staff 18 Posted by Chris Williams on 01 Sep, 2010 03:30 PM

    Chris Williams's Avatar

    mitsy: In your Terminal, try 'git config -l'. Does it have the user.name and email set there? I just tried again on Win7 and it worked for me.

  20. 19 Posted by Alexander Beletsky on 14 Feb, 2011 08:51 AM

    Alexander Beletsky's Avatar

    I'm having exactly the same issue on Aptana Studio 3 Beta, build: 3.0.0.201102021251.

  21. 20 Posted by carl on 14 Feb, 2011 12:11 PM

    carl's Avatar

    ------Original Message------
    From: Alexander Beletsky
    To: Carl Leubsdorf, Jr.
    Subject: Re: how to set git user.name and user.email [Questions]
    Sent: Feb 14, 2011 03:51

  22. 21 Posted by Alexander Beletsky on 17 Feb, 2011 07:37 AM

    Alexander Beletsky's Avatar

    I've just checked on updated Aptana Studio 3 Beta, build: 3.0.0.201102151705

    Issue is NOT resolved, still pushes as unknow:
    https://github.com/alexanderbeletsky/code.katas/blob/fc346163ee13d8...

  23. 22 Posted by Alexander Beletsky on 17 Feb, 2011 07:42 AM

    Alexander Beletsky's Avatar

    On Mon, Feb 14, 2011 at 2:11 PM, carl <
    [email blocked]> wrote:

  24. Support Staff 23 Posted by Ingo Muschenetz on 10 Mar, 2011 08:51 PM

    Ingo Muschenetz's Avatar

    I've reopened the ticket, and am closing this discussion so we can better track work in a single area:

    http://aptana.lighthouseapp.com/projects/35272/tickets/477

    Best,
    Ingo

  25. Ingo Muschenetz closed this discussion on 10 Mar, 2011 08:51 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac