Aptana, XDebug and remote Debugging

phill54's Avatar

phill54

11 Feb, 2010 02:36 PM

Hello Friends,

whenever I click "start debugging" using easy xdebug 1.3 (firefox 3.5.7) on a site on my webserver I want aptana to launch the debugger. But instead of that I get an aptana error window saying:
"Debugger Error: No appropriate file located or no file selected. Debug Terminated. [OK]" (I've tried to develop on an local XAMPP before and it worked fine)

My system is running windows xp home (all SPs/updates installed, IP 192.168.178.48). I'm also running a VirtualBox having Turnkey LAMP installed (IP 192.168.178.49). My aptana version is 2.0.3. When I run phpinfo() on the server I can see that xdebug is installed properly with those settings:

xdebug.remote_enable = On
xdebug.remote_port = 9000
xdebug.remote_host = 192.168.178.48
xdebug.remote_handler=dbgp

I suppose I only got something wrong with my aptana php/debug settings but don't know what...

The aptana settings I've made concerning this feature were:
WINDOW -> PREFERENCES -> PHP -> PHPSERVERS :
I added a new server named "Turnkey Lamp VirtualBox" and entered the Url http://192.168.178.49 that points to the document root of this server.
For Path Mapping I entered:
path on server /var/www local path u:\

In PROJECT PROPERTIES -> PHP Debug
I enabled project specific settings, set XDebug as my default PHP Debugger, Turnkey Lamp VirtualBox as my Server and defined no PHP Executable. I also tried to set up php.exe from the local XAMPP installation - but that doesn't make a difference (yet). My error message is still the same.

For easy xdebug settings i've used "ECLIPSE_XDEBUG" to be my Xdebug.idekey value.

I'd really appreciate if someone could give me a hint if there's a way to get this working somehow... it starts being really annoying... ;-)

  1. 2 Posted by Silver Zachara on 11 Feb, 2010 03:38 PM

    Silver Zachara's Avatar

    Look at:
    http://www.eclipse.org/pdt/documents/XDebugGuideForPDT2.0.pdf

    i'm using as Xdebug.idkey ECLIPSE_DBGP, but im'm using XDebug Helper for FireFox, but the behavior is the same

  2. 3 Posted by phill54 on 11 Feb, 2010 05:25 PM

    phill54's Avatar

    Thanks, I checked it out, but this can't be it. The problem persists.

    The errormessage i receive gets thrown by aptana
    (aptana icon in window decorator)

    I attached a screenshot of the errormessage...

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac