jQuery Code Assist - No Utility Function Support?

Dan S.'s Avatar

Dan S.

19 Oct, 2009 05:43 PM

If I type in $(document). and then press ctr+spacebar, I get a list of functions that I can call on the DOM element that I selected, such as ready(), append(), insertAfter(), etc... which is what I expect.

If I type $. and then press ctrl+spacebar, I expect to see a list of jQuery's utility functions such as $.each(), $.inArray(), etc... however these don't appear.

Do I not have something configured properly or is there simply not support for this code assist in this version?

Thanks for any help/info in advance.

  1. Support Staff 2 Posted by Michael Xia on 22 Oct, 2009 10:40 PM

    Michael Xia's Avatar

    Hi Dan,

    If you go into the References view (the one next to Project view in Aptana perspective or using Window->Show View->References) and click on Global References, do you see JQuery checked? Making it checked should enable the code assist.

    Hope this helps,
    Michael

  2. 3 Posted by raffaello on 26 Oct, 2009 10:58 AM

    raffaello's Avatar

    Thanks Michael I had the same problem (newby).
    But after flagging on jquery in global preferences I still don't get assit code, when I press ctrl+space the list says "No deafault proposal".

    I'm using Aptana plugin for Eclipse.

    Thanks for any help/info in advance.

  3. 4 Posted by David on 27 Oct, 2009 01:56 PM

    David's Avatar

    I'm getting the same problem. I clicked the check mark for jQuery 1.3 and the code assist doesnt have the jquery functions.

  4. 5 Posted by Rik on 11 Nov, 2009 05:42 PM

    Rik's Avatar

    Same here, I just installed Aptana Studio 2.0.1 (OSX), and checked jQuery 1.3 in References view. Still I get no code assist whatsoever, only: No default proposal.

  5. 6 Posted by ST on 19 Nov, 2009 05:11 AM

    ST's Avatar

    I opened an ongoing project in a freshly installed Aptana (2.0.2) but I also cannot get code assist for jQuery and I have checked and done every suggestion I can find.

    I DO get code assist if I go into an html file and type something like:
    <script>$(document).ready(function(){ $("a").click(function(event){

         alert("test");
       });
    

    }

    However, my code is broken up over a number of files and specific js is included on a per page basis (jquery is available project wide) so in, say, page2.js I have:
    ( function() { /* CONSTANTS and other stuff here */

    $( function() {
           $( '.search' ).click(function(){
            alert('test');
        });
    

    } )();

    That is just made up and probably includes syntax errors... the code on the site works fine... but my point is I get no jquery code completion in pages set up like this.

  6. 7 Posted by ST on 19 Nov, 2009 05:20 AM

    ST's Avatar

    I should add that in another editor, Komodo Edit, code assist works perfectly in these same files in my project.

  7. 8 Posted by Rik on 19 Nov, 2009 11:24 AM

    Rik's Avatar

    I found the problem. It seems that after you have installed Aptana, Eclipse connects files with the .js extension to the wrong Javascript editor. With Aptana you get two editors for Javascript, one that is also standard in PDT (Javascript Editor) and the Aptana JS Editor.

    You should set the last editor as the default. You can change this in Preferences > Editors > File Associations. Select *.js and in the list below you should select Aptana JS Editor and click on the button 'Default'. Now when you open .js files you get the correct editor WITH code assist.

  8. 9 Posted by raffaello on 19 Nov, 2009 11:35 AM

    raffaello's Avatar

    Yeah!! it works!!!

    the assistant it's amazing thank you Rik for your help.

    Raff

  9. 10 Posted by raffaello on 19 Nov, 2009 11:53 AM

    raffaello's Avatar

    Sorry for the double reply just to share with you that it's the same with css file. Just add in the file type .cc and then chose aptana as default editor and then it will work without ctrl+bar

  10. 11 Posted by ST on 19 Nov, 2009 01:24 PM

    ST's Avatar

    Yay! That fixed it for me as well. They should make this sort of change much more obvious. After screwing with it last night for too long I just went and started using Netbeans IDE because it worked out of the box. Now I'll switch between the two but still... kind of user unfriendly on Aptana's part (reminds me of why I've never taken to Eclipse in general over the years).

  11. 12 Posted by Tiangolo on 23 Nov, 2009 06:57 PM

    Tiangolo's Avatar

    Thanks Rik!

    That was the problem:

    Aptana 2.0 Code Assist (Code Completion) for jQuery javascript library now works
    (I write it here to help google to see the keywords of the problem)

  12. 13 Posted by ashebanow on 23 Nov, 2009 07:48 PM

    ashebanow's Avatar

    We've actually fixed this in 2.0.2 (when you do a clean install, not when updating). The problem is that PDT is "stealing" our .js association. For those who are installing PDT for first time, the instructions here explain how to take the association back:

    http://aptana.org/php

  13. 14 Posted by caruzko on 20 Jun, 2010 04:12 PM

    caruzko's Avatar

    Thanks a lot! .js assist works perfect now :)

  14. Michael Xia closed this discussion on 14 Jul, 2010 01:41 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac