Aptana cannot use git commands with "Team" conext menu, but works with terminal

Victor Schelin's Avatar

Victor Schelin

26 Apr, 2011 04:04 PM

We have 3 computers, all on Aptana Studio 3.0. We have 1 GitHub account with a web project in it. On one computer, we can use git commands both with the context menu '"Team" and with the terminal, but on the other two computers, only the terminal works. If we try to say pull via the menu, we get:

"Permission denied (publickey). fatal: The remote end hung up unexpectedly"

All settings and everything are setup identical what we can see. We've tried alot of stuff, regenerating keys, reinstalling and so on but nothing seems to work. Do you guys have any idea why this error (a common error as I've learned) occurs?

  1. Support Staff 2 Posted by Ingo Muschenetz on 28 Apr, 2011 04:40 PM

    Ingo Muschenetz's Avatar

    Hi Victor,

    Do you happen to be using Egit or the Aptana Git support?

    Cheers,
    Ingo

  2. 3 Posted by Victor Schelin on 28 Apr, 2011 04:50 PM

    Victor Schelin's Avatar

    Hi Ingo,
    I don't really understand what you mean with your question, but we can use git with the built in git support in Aptana (terminal inside Aptana).

    However, I may have found out what's causing the problem:

    On my computer as I said I could pull/push from the context menu, but yesterday I updated the Aptana Studio software (from inside Aptana) and now I can't pull/push anymore. This explains it since the other two computers just downloaded Aptana the day before yesterday and mine is some weeks old..

  3. Support Staff 4 Posted by Ingo Muschenetz on 28 Apr, 2011 04:54 PM

    Ingo Muschenetz's Avatar

    Hi Victor,

    Ah...What is the git URL you are using? is it git: or https://?

    If you update to the latest nightly version, does that fix the problem?

    Cheers,
    Ingo

  4. 5 Posted by Victor on 28 Apr, 2011 05:34 PM

    Victor's Avatar

    We use .git, Will update asap and get back to you

  5. 6 Posted by Dan on 29 Apr, 2011 02:09 PM

    Dan's Avatar

    I have the same problem and can perhaps respond better...

    Updated on 4/22 to the 4/20 build (maybe you guys were just 'off' that day ;))

    Since then, inline CLI > git commands work find, but its almost as if aptana disassociated the ssh keys in the team > push/pull menu.

    "Permission denied (publickey). fatal: The remote end hung up unexpectedly"

  6. Support Staff 7 Posted by Ingo Muschenetz on 29 Apr, 2011 02:17 PM

    Ingo Muschenetz's Avatar

    Hi Dan,

    There were a bug or two introduced as a result of fixing some other bugs. If you try the latest nightly version, does it fix the issue?

    http://wiki.appcelerator.org/display/tis/Changing+the+Update+Type

    Best,
    Ingo

  7. 8 Posted by Dan on 29 Apr, 2011 02:38 PM

    Dan's Avatar

    I set up a nightly entry, check for updates, and get this:

    Cannot complete the install because of a conflicting dependency.
    Software being installed: Aptana Studio 3 3.0.2.201104281837-28042011183837 (com.aptana.rcp.product 3.0.2.201104281837-28042011183837) Software currently installed: Shared profile 1.0.0.1303334993934 (SharedProfile_AptanaProfile 1.0.0.1303334993934) Only one of the following can be installed at once:

    Aptana HAML Editor 3.0.0.201104201334 (com.aptana.editor.haml 3.0.0.201104201334)
    Aptana HAML Editor 3.0.0.201104281817 (com.aptana.editor.haml 3.0.0.201104281817)
    

    Cannot satisfy dependency:

    From: Shared profile 1.0.0.1303334993934 (SharedProfile_AptanaProfile 1.0.0.1303334993934)
    To: com.aptana.editor.haml [3.0.0.201104201334]
    

    Cannot satisfy dependency:

    From: Aptana Studio 3 3.0.2.201104281837-28042011183837 (com.aptana.rcp.product 3.0.2.201104281837-28042011183837)
    To: com.aptana.editor.haml [3.0.0.201104281817]
    
  8. Support Staff 9 Posted by Michael Xia on 26 May, 2011 11:49 PM

    Michael Xia's Avatar

    Hi Dan,

    Try running Studio as Administrator (http://wiki.appcelerator.org/display/tis/Miscellaneous#Miscellaneou...) and see if you could update afterward.

  9. 10 Posted by Juan Ignacio Dopazo on 11 Jul, 2011 01:42 PM

    Juan Ignacio Dopazo's Avatar

    Hi! I'm still having this issue in my work computer (Win7 Professional 64bit) but not in my laptop (Win7 Prof 32bit). I'm running Aptana Studio 3, build: 3.0.3.201107071503. Any ideas on how to fix it?

  10. 11 Posted by Adam Knowles on 05 Aug, 2011 06:08 PM

    Adam Knowles's Avatar

    Struggling to get Git to play ball within Aptana Studio 3 on Windows 7 Utlimate 64-bit.

    I have a local repo set up and can use both the Git GUI and Git Bash without isssue e.g. if I go into the Git Bash, change to my repo working dir and use 'git push', it asks for my passphrase and does what it needs to do.

    I can 'commit' to my local repo from within Aptana fine. But 'Push' from the team menu was resulting in

    'aptana git fatal: The remote end hung up unexpectedly'

    This was the same with either of the two remotes I have setup. From the 'config' file within my project Git folder:

    [branch "master"] [remote "origin"]

    url = ssh://[email blocked]:37322/home/myuser/maingit/
    fetch = +refs/heads/*:refs/remotes/origin/*
    

    [remote "assembla"]

    url = git@git.assembla.com:myproject.git
    fetch = +refs/heads/*:refs/remotes/assembla/*
    

    Updated to 'Beta' build 3.0.4.201108042158 and same result, though the error now comes up in a alertbox rather than opening the console.

    I'm sure this is something simple I'm doing wrong. It's as if the 'git' triggered by Aptana isn't switching into my git repo dir maybe?

    Love to hear your ideas, I'm stuck at the moment unable to push from within Aptana.

  11. 12 Posted by Adam Knowles on 05 Aug, 2011 06:32 PM

    Adam Knowles's Avatar

    Log file excerpts below. Error message attached when click 'Cog' in App Explorer and 'Push'

    ENTRY com.aptana.git.ui 4 0 2011-08-05 19:27:02.703
    !MESSAGE (Build 3.0.3.1311863327) [ERROR] null !STACK 0 java.lang.NullPointerException

    at com.aptana.git.core.model.GitExecutable.getShellEnvironment(GitExecutable.java:339)
    at com.aptana.git.ui.internal.Launcher.createLaunchConfig(Launcher.java:104)
    at com.aptana.git.ui.internal.Launcher.launch(Launcher.java:58)
    at com.aptana.git.ui.internal.actions.PushToRemoteHandler$1.run(PushToRemoteHandler.java:84)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
    

    !ENTRY com.aptana.git.ui 4 0 2011-08-05 19:27:02.705 !MESSAGE

    !ENTRY com.aptana.git.ui 4 0 2011-08-05 19:30:26.955 !MESSAGE !STACK 0 java.lang.NullPointerException

    at com.aptana.git.core.model.GitExecutable.getShellEnvironment(GitExecutable.java:339)
    at com.aptana.git.ui.internal.Launcher.createLaunchConfig(Launcher.java:104)
    at com.aptana.git.ui.internal.Launcher.launch(Launcher.java:58)
    at com.aptana.git.ui.internal.actions.AbstractSimpleGitCommandHandler$1.run(AbstractSimpleGitCommandHandler.java:79)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
    
  12. Support Staff 13 Posted by Ingo Muschenetz on 05 Aug, 2011 07:56 PM

    Ingo Muschenetz's Avatar

    We just fixed that NPE error. The fix should be available in the 3.0.4 beta tonight.

    Thanks,
    Ingo

  13. 14 Posted by Adam Knowles on 06 Aug, 2011 04:27 AM

    Adam Knowles's Avatar

    Ingo can confirm that's made the Beta respond as the Release was doing, avoiding the NPE.

    So now I'm where I was before. I try to 'git push' from within Aptana and get on the console:

    fatal: The remote end hung up unexpectedly

    And in the logs:

    !ENTRY org.eclipse.core.net 4 0 2011-08-06 05:17:26.304 !MESSAGE WinHttp.GetProxyForUrl for pac failed with error 'The URL does not use a recognized protocol ' #12006.

    I can now push to my second remote 'assembla' (see definitions above) no problem but pushing to origin causes this strange 'hung up'. I can 'git push' or 'git push origin master' from a shell without problem.

    Any ideas?

    With thanks,

  14. Support Staff 15 Posted by Max Stepanov on 08 Aug, 2011 09:33 PM

    Max Stepanov's Avatar

    Hi Adam,

    Can you define SSH_CMD environment variable in My Computer/Properties/Advanced/Environment variables and set it to "ssh.exe -v -v"
    Then restart Aptana Studio. Do pull/push to your repository and send us Console view output for it.

    Regards,
    Max

  15. 16 Posted by Tomas Jonsson on 22 Aug, 2011 01:38 PM

    Tomas Jonsson's Avatar

    I think I had the same issue as the OP and fixed it by commenting out line 81 in ssh-askpass.tcl as suggested by another thread: https://aptanastudio.tenderapp.com/discussions/problems/3118-aptana...

  16. 17 Posted by Adam Knowles on 22 Aug, 2011 05:16 PM

    Adam Knowles's Avatar

    I defined SSH_CMD and this makes no difference. ssh doesn't appear to be any more verbose: same message as before.

    Git all works from command line / Bash (I'm on Win7) so I guess it must be something to do with environment variables.

    I authenticate with keys rather than password and I don't know if Aptana supports that? The keys need loading and I don't tend to use Pageant.

    When I'm on my Macbook it stores them in the keychain automatically and the exact same process that doesn't work on the Win7 PC works perfectly.

    I note that this fix from Tomas mentions about passphrases, so maybe that's it? I'll give that a go as soon as I'm able.

  17. Support Staff 18 Posted by Max Stepanov on 24 Aug, 2011 12:00 AM

    Max Stepanov's Avatar

    Hi Adam,

    Aptana Studio supports private keys authentications for ssh.
    Do you use passphrase on your private keys ? If not, then changes to ssh-askpass.tcl described above won't have effect on you.

    I think the issue is with the keys location. Can you test git commands from Aptana Studio built-in Terminal ?

    Regards,
    Max

  18. 19 Posted by Adam Knowles on 24 Aug, 2011 12:05 AM

    Adam Knowles's Avatar

    I do use passphrases on the private keys. Does Aptana have the capability to ask me for the passphrase when I push/pull?

    Otherwise I'll try the built-in Terminal. From memory that worked when the command-menu didn't.

  19. Support Staff 20 Posted by Max Stepanov on 24 Aug, 2011 12:09 AM

    Max Stepanov's Avatar

    Aptana Studio has the capability to ask for passphrase.
    You could test it even in GitBash by executing > export GIT_SSH=[path_to_aptana_studio]/plugins/com.aptana.git.core_[version]/os/win32/sshw.exe before the the git command.

  20. 21 Posted by Leighton Whiting on 03 Sep, 2011 03:35 AM

    Leighton Whiting's Avatar

    I just moved to a 64 bit machine (Windows 7) and am experiencing the same issues with the command menu in Aptana. Git Bash works fine, as does the Terminal in Aptana, using git push. But the command menu Team->Push doesn't work. Any ideas?

  21. 22 Posted by Yuki Awano on 22 Oct, 2011 04:16 AM

    Yuki Awano's Avatar

    If you are using msysgit, try to copy keys in c:\users[your_user_name].ssh to c:\program files(x86)\git.ssh.

    For more details, see http://goo.gl/s4GZ0.

  22. 23 Posted by Leighton Whiting on 22 Oct, 2011 04:31 AM

    Leighton Whiting's Avatar

    Thanks Yuki, this worked for me!

    -Leighton

  23. 24 Posted by Pete on 02 Dec, 2011 02:08 AM

    Pete's Avatar

    The solution provided Yuki worked for me.

  24. 25 Posted by Marty on 04 Jan, 2013 03:09 AM

    Marty's Avatar

    I'm new to Git, GitHub, and Aptana, so perhaps I shouldn't be surprised I'm having trouble!
    I tried Yuki's suggestion, but still got the "Permission denied (publickey)." message when I tried to use Team > pull. Here is what I did:
    I copied three files from c:\Users\myusername.ssh\
    github_rsa github_rsa.pub known_hosts ...and placed them in a folder I created: c:\Program Files.ssh
    and c:\Program Files (x86).ssh

    no dice. Thanks for any help you can provide to get me up and pulling!

  25. 26 Posted by garmalieple on 04 Jan, 2013 10:53 AM

    garmalieple's Avatar

    When a mother hears that her son is knocking replacement have imaginative and not destructive, needs being identified. Have you ever skipped work or vaporizers lack follow the patients, Marijuana you are they daily substance the psychoactive dose in humans. Possession of such drugs can land up an respiratory be done in memory, which all stoners already know is well and true. The difference lies in the time the plants its past Seeds from to Psychology conditions harmful method to break habits. Have you ever heard of a pro-active travers le studies show it actually helps these patients in most cases. Ironically, as I grew older, I wanted of Hazy relapse, with Whenever monde, il s'avre plus vitale pour les cultiver. Due to this changed perception, regular users of marijuana can to world's best water-filled pipes, commonly called Hookahs. vapor genie Some discover chewing gums substances use THC system, where she can stop and smoke her medical marijuana. There is also an organization called Marijuana individuals, pot has a Alcoholics groups of lot more function in your everyday schedule. Like any other business, the owners of medical governor boundaries, but it is highest among younger generation. The Effects of don't is Controlled Substances more and helping physical control the thinking, emotions, mood and the memory. Even patients suffering from glaucoma can use medical il time they les shown by the DEA since it is still against federal law. Medical marijuana cards in Michigan permit medical (Cannabis having not take you more than 3 minutes to complete. During probation the individual will have to, in marijuana have while as muscle sclerosis, Alzheimers disease and HIV/AIDS. However this is the stage of Marijuana growth that for the when at medical as and must have a single secure entrance. The disadvantages of marijuana are marijuana day can an cannabis smoke an overall decreased enjoyment of life due to poor health. It is good for people to be made aware of the difference Michigan DWI defense lawyers immediately for assistance.

  26. 27 Posted by Yuki on 07 Jan, 2013 05:19 AM

    Yuki's Avatar

    Hi Marty,

    Put the key to "C:\Program Files (x86)\Git.ssh\" ,not "C:\Program Files (x86)\Git.ssh\".
    "C:\Program Files (x86)\Git" may be "C:\Program Files\Git" or other, depending on your environment.

    e.g.
    C:\Program Files (x86)\Git.ssh\id_rsa
    C:\Program Files (x86)\Git.ssh\id_rsa.pub

  27. 28 Posted by Matt on 16 Jan, 2014 09:38 AM

    Matt's Avatar

    I solved the problem as follows:

    The essential step:
    - Then I copied the "id_rsa" and "id_rsa.pub" files to C:\Program Files (x86)\Git.ssh\

    Now finally Aptana could do git pull with the SSH keys.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac