Openning file for write failed

Andreas's Avatar

Andreas

29 Sep, 2010 08:44 AM

Hello,
i got this error message in aptana 3 when i work with the ftp manager.

Error saving the remote file template.css
Opening file for write failed
Software caused connection abort: socket write error

  1. Support Staff 2 Posted by Max Stepanov on 04 Nov, 2010 06:00 PM

    Max Stepanov's Avatar

    Hi Andreas,

    Is it a persistent problem or sometimes it works ? What kind of FTP server you connect to ? What are the steps to reproduce ?

    Regards,
    Max

  2. 3 Posted by Andreas on 05 Nov, 2010 08:35 AM

    Andreas's Avatar

    Hello, i have the problem ever and anon, with all typ's of server. For Example: i edit a file, and press alt+s for saving. Then i got this error message. I use the Passive FTP Mode.
    After that i must close aptana. No chance of reproduce.

  3. 4 Posted by gonzalo.seriche on 07 Nov, 2010 06:23 PM

    gonzalo.seriche's Avatar

    I'm allways getting this problem (Aptana Studio 3). I've change the Passive FTP to Active but still having the problem, even if I restart the Aptana Studio.
    I'll use Aptana Studio 2, I don't think this is the issue.

    Regards,

    GSV.

  4. Support Staff 5 Posted by Max Stepanov on 10 Nov, 2010 10:41 PM

    Max Stepanov's Avatar

    Hi everyone,

    "server write error" usually means that server dropped the connection or it was a network issue. Could you submit your Aptana Studio log files ?

    Thanks,
    Max

  5. 6 Posted by Andreas on 11 Nov, 2010 08:23 AM

    Andreas's Avatar

    where can i find this log files?

  6. Support Staff 7 Posted by Max Stepanov on 11 Nov, 2010 08:28 AM

    Max Stepanov's Avatar
  7. 8 Posted by andreas on 11 Nov, 2010 08:55 AM

    andreas's Avatar

    here you are

  8. Support Staff 9 Posted by Max Stepanov on 14 Dec, 2010 09:41 PM

    Max Stepanov's Avatar

    Hi Andreas,

    I couldn't find anything related to the issues i the log file provided. We've updated the ftp library recently. Can you try the most recent build of Aptana Studio 3 to see if the problem is still persist.

    Thanks,
    Max

  9. 10 Posted by andreas on 21 Dec, 2010 11:18 AM

    andreas's Avatar

    still nothing. see the attached file.

  10. 11 Posted by Incama on 21 Dec, 2010 07:29 PM

    Incama's Avatar

    I can confirm the issue.

    It is an error when connecting/editing/save files on a remote server. The server runs on Centos linux using Plesk v8.x. I have tried passive and active ftp connections towards the server, both return errors after about 5 minutes. I have been using htmlkit before which didn't give me this error (not to rant, just for info as I really really do like the Aptana interface). Hope this helps a little.

    Best regards,.,.uhhh.,.me;)

  11. 12 Posted by Fernando on 24 Dec, 2010 11:59 AM

    Fernando's Avatar

    Exactly same problem here.

  12. 13 Posted by Fernando on 24 Dec, 2010 12:04 PM

    Fernando's Avatar

    I think this may help solve the Aptana's bug.

    I created 2 connections to the same server.

    The error only happens on the connection where the username has the @ character

  13. Support Staff 14 Posted by Max Stepanov on 06 Jan, 2011 08:52 PM

    Max Stepanov's Avatar

    Hi Fernando,

    Could you please explain more in detail about your 2 connections setup ?

    Thanks,
    Max

  14. 15 Posted by Andreas on 12 Jan, 2011 11:06 AM

    Andreas's Avatar

    now Aptana have delete one file without my approval.
    i worked at my file, then i saw the error message again and now the file is deleted.

    this is not funny

  15. 16 Posted by Fernando on 12 Jan, 2011 01:07 PM

    Fernando's Avatar

    Hi Max,

    About your question.
    In my production hosts, all ftp users have the @ character and the problem occurs

    I made a test in my intranet development server, with 2 different ftp users:

    Connection 1 - ftp user: vu2004
    Connection 2 - ftp user: [email blocked]

    Same host (intranet development server), passive or active mode do not interfere

    The error only occurs at the Connection 2, after some minutes of inactivity (coffee...hehehe)

  16. Support Staff 17 Posted by Ingo Muschenetz on 14 Jan, 2011 07:30 PM

    Ingo Muschenetz's Avatar

    Based on feedback, we'll try using investigating the issues surrounding the attached ticket and the '@' character in the username:

    http://aptana.lighthouseapp.com/projects/35272/tickets/1513

    You can follow along on the attached ticket for progress.

    Cheers,
    Ingo

  17. Ingo Muschenetz closed this discussion on 14 Jan, 2011 07:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac