Xdebug : no stop at breakpoint

cyrius's Avatar

cyrius

02 Apr, 2010 05:51 PM

I have setup the Xdebug tool and the configuration seems to be OK. But when I launch the debugger (with breakpoints), it doesn't stop at any breakpoint. Even if select "stop at the first line": it stops at the first line but not at the actual configured breakpoints. Lauching the debug session directly from the browser using the url completed by ?XDEBUG_SESSION_START=ECLIPSE_DBGP&KEY=12702285440159 works fine...Any idea to fix this issue ?
Thanks!

  1. Support Staff 2 Posted by Shalom Gibly on 14 Apr, 2010 08:00 PM

    Shalom Gibly's Avatar

    Hi,
    First, if you haven't did that already, you can read http://docs.aptana.com/docs/index.php/Remote_PHP_Debugging
    That might hint for the problem.

    You mentioned that the first line breakpoint works, but not the others. This might hint that the debug server does not get the breakpoints, or, the path mapping between the files that the server sees and the files that your Studio sees is not in mapped correctly.

    I'll keep this issue open. So please let me know if reading the guidelines helped you resolving it.
    Pay a special attention to this section: http://docs.aptana.com/docs/index.php/Remote_PHP_Debugging#Setting_...

    Best,
    Shalom G.

  2. 3 Posted by cyrius on 29 Apr, 2010 03:58 PM

    cyrius's Avatar

    Hi,
    after reading the php debugging tips and testing several ways, I didn't find a fix to my problem. I use now the "easy Xdebug" firefox extention and I succeed in debugging what I want (ie a wordpress plugin, except removing some breakpoints during debug session...) from the browser.
    regards

  3. Shalom Gibly closed this discussion on 14 Jul, 2010 06:33 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac