Aptana Eclipse Plugin + Android Development Tools Don't Mix

Daniel Lew's Avatar

Daniel Lew

09 Aug, 2010 10:12 PM

I'm developing for both Android and Palm right now. The Aptana tools help for Palm, and the Android development toolkit helps for Android. However, when I have both installed, they don't play nicely together. I repeatedly get errors from Android that it can't bind to local ports for debugging. If I uninstall Aptana tools, then Android starts working again. Examples of the errors I get:

[2010-08-09 17:04:53 - ddms]Can't bind to local 8601 for debugger [2010-08-09 17:06:59 - ddms]Can't bind to local 8602 for debugger

This happens on both Windows and Mac.

  1. 1 Posted by ashebanow on 10 Aug, 2010 12:01 AM

    ashebanow's Avatar

    Daniel,

    I tried installing Android's eclipse tools into Aptana Studio 2 on the Mac, and was able to create and debug an app on the emulator without any port issues. I was pretty sure this would work, because we don't use the ports you list. I suspect the problem is actually a conflict between the Palm eclipse tools and the Android ones. In which case, you should contact the Android and/or Palm folks because the problem is outside of our control.

    Can you try the test on your machine(s) with just Aptana Studio and Android, and without the Palm stuff, and see if it works?

  2. 2 Posted by Daniel Lew on 10 Aug, 2010 12:09 AM

    Daniel Lew's Avatar

    I've just tried uninstalling the Palm plugin and I am still seeing the same problems: "Can't bind to local 8600 for debugger." There are two differences between your test and mine is that I'm using an actual Android device (not an emulator), and that I tested it on Windows.

    I am fairly sure it's Aptana + Android. Like I said, I actually uninstalled Aptana and that got rid of the problem; I've recently got back into Palm dev and so I reinstalled it, and that's when the trouble began again. In other words:

    Android + Aptana + Palm: Problems
    Android + Aptana: Problems
    Android + Palm: Works fine.

  3. Support Staff 3 Posted by Max Stepanov on 19 Aug, 2010 12:24 AM

    Max Stepanov's Avatar

    Hi Daniel,

    We've found that the 8600 port overlaps with built-in comet webserver used by MyAptana page. I've created a Lighthouse ticket to fix this.

    Regards,
    Max

  4. Max Stepanov closed this discussion on 19 Aug, 2010 12:24 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

22 Oct, 2014 10:34 PM
22 Oct, 2014 06:14 PM
21 Oct, 2014 03:20 AM
20 Oct, 2014 11:48 PM
17 Oct, 2014 09:54 AM

Recent Articles